Article Marketing Robot

Article Marketing Robot Discussion Forum
It is currently Mon Sep 01, 2014 11:38 pm

All times are UTC - 7 hours




Post new topic Reply to topic  [ 22 posts ] 
Author Message
 Post subject: Beta Test 1.0.8.*
PostPosted: Tue Nov 30, 2010 5:06 pm 
Offline
Site Admin

Joined: Thu Apr 08, 2010 3:25 pm
Posts: 3656
Ok - I have a beta version for you to try.

First - Back up your database.

1) Run AMR from your start menu, click file - open database,
2) right click the .mdb file
3) close the open database dialog
4) paste somewhere on your computer

Download this file and save it to program files/article marketing robot

http://www.articlemarketingrobot.com/AMR.exe

Run this file from the program files folder, not from the start menu

The version will look like 1.0.7.8

Let me know how things go. I am doing this release slowly as I am going on vacation in a week or so, and don't want to be putting out fires while I'm supposed to be putting on sunscreen ;)

Chances are this release won't officially happen until after I get back, Dec 20, but this is what you will be getting anyways. At any rate, if you get errors or bugs, you will still have your original .exe file


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Tue Nov 30, 2010 10:57 pm 
Offline

Joined: Sun Sep 19, 2010 10:37 pm
Posts: 79
Sniper wrote:
Ok - I have a beta version for you to try.

Download this file and save it to program files/article marketing robot

http://www.articlemarketingrobot.com/AMR.exe

Run this file from the program files folder, not from the start menu

The version will look like 1.0.7.8

Let me know how things go. I am doing this release slowly as I am going on vacation in a week or so, and don't want to be putting out fires while I'm supposed to be putting on sunscreen ;)

Chances are this release won't officially happen until after I get back, Dec 20, but this is what you will be getting anyways. At any rate, if you get errors or bugs, you will still have your original .exe file


We will hold back the fires for you till you come back ;)

I have downloaded it and will post you after doing extensive usage (in any case i do it on everyday basis).


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Wed Dec 01, 2010 2:16 am 
Offline

Joined: Sun Oct 31, 2010 2:42 am
Posts: 25
I'm afraid I'm having some problems...

I tried creating a new catagory for my nich and the open "add catagory" window said "not responding".

AMR locked up.

I went into task manager and killed it.

Then when I tried to load it again, the little robot splash screen comes up and never goes away. The AMR.EXE process seems to be using 50% of my cpu, but doesn't look like it's doing anything.

The program does not seem to load any more.

I even tried rebooting but I can not get the new version to work a second time.

(old version still loads though)

I am using a machine with windows XP service pack 3 with latest updates.

- Leo


Last edited by Leo on Wed Dec 01, 2010 9:21 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Wed Dec 01, 2010 9:19 am 
Offline

Joined: Sun Oct 31, 2010 2:42 am
Posts: 25
Gak!

Since attempting the beta, I can no longer submit articles with the regular version 1.0.7.6

I get a message: Unhandled exception: Conversion from type "DBNull" to type "String" not valid


************** Exception Text **************
System.InvalidCastException: Conversion from type 'DBNull' to type 'String' is not valid.
at Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
at ArticleMarketingRobot.mod_Submit.dosubmit(Boolean bSched, String id, String email, Int32 iArticleMethod, String artLoc, Int32 iLimit, String idno)
at ArticleMarketingRobot.frmMain.cmdSubmit_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Wed Dec 01, 2010 9:25 am 
Offline

Joined: Sun Oct 31, 2010 2:42 am
Posts: 25
Ok... It looks like I have a corrupted data base.

If I swap out an older backup of the data base, I can get the new version to run again...

I don't suppose there is a way to recover this particular db, is there?


Last edited by Leo on Wed Dec 01, 2010 9:48 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Wed Dec 01, 2010 9:38 am 
Offline
Site Admin

Joined: Thu Apr 08, 2010 3:25 pm
Posts: 3656
Right - AMR doesn't use the 6 category boxes any more so new articles created in the new .exe will leave those old cat boxes blank thus creating a null exception for the old .exe


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Wed Dec 01, 2010 10:40 am 
Offline
Site Admin

Joined: Thu Apr 08, 2010 3:25 pm
Posts: 3656
Leo wrote:
I tried creating a new catagory for my nich and the open "add catagory" window said "not responding".


Can you create a step by step scenario on the exact things you did? I don't fully understand this..


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Wed Dec 01, 2010 1:28 pm 
Offline

Joined: Sun Oct 31, 2010 2:42 am
Posts: 25
Sorry... I mis-spoke, which is probably why you couldn't follow. I was in "saved categories", not "Add Categories."

Here is what I did:

saved categories:

1) Go to "Select targets"
2) Right click on directories
3) select Categories/SaveCategories
4) Add
5) (enter new category niche name) then hit ok
6) Enter box closes, Save category box is still open.

There is an hourglass that does not go away.
If I try to close that window (I let it run for nearly 10 minutes) I get the "this program is not responding".

I close down the program, and then it will no longer open again until I copy my backup of the data base back into the folder. It just freezes on the little robot splash screen.

I was trying to create a niche name that I could add a list of acceptable categories to.

- Leo


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Wed Dec 01, 2010 2:10 pm 
Offline

Joined: Sun Oct 31, 2010 2:42 am
Posts: 25
I'm not sure I am understanding how the right click category options are supposed to work.

I am attempting to set things up so that if a directory does not have one of the categories listed in my article that it's default behavior is no submit.

Here is what I am doing:
1) I add a comma delimited list of categories to my article
2) Go to Select targets
3) right click on a directory and select Catagory/detect Categories.

Poof. Like magic, the Category column of all directories update to one of the category groups in my article's list. (Very, VERY cool!)

The problem is if there is no match, the category defaults to "Random" or "Let AMR Decide" and I need the Category associated with that directory to be set to "Skip Submission".

Not sure what to do to fix that.

I'm also not sure how/when to use the right-click Categories/Apply Saved Categories, or how to set up a new Saved category. (I'm guessing Saved Category needs to be set up with the default of no Submit but that I can't because of the crash that I get?)

Anyway, please set me straight as to what I need to do to change the default submit behavior.

Thanks!


Last edited by Leo on Thu Dec 02, 2010 1:43 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Wed Dec 01, 2010 5:17 pm 
Offline
Site Admin

Joined: Thu Apr 08, 2010 3:25 pm
Posts: 3656
This is how I designed it to work:

1 - "Detect Categories"
2 - "Save Categories"
3 - Add or use an existing "Save Categories As..."
4 - Your default behavior.
5 - Click OK

There wasn't really a better place to put the default behavior because I wanted to keep it niche specific.


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Thu Dec 02, 2010 2:03 am 
Offline

Joined: Sun Oct 31, 2010 2:42 am
Posts: 25
Ok. That's what I thought.

I've been having big problems with Save Categories.

Each time I attempt it, it does something to the db and locks AMR (and prevents the new version from opening again on subsequent attempts... old version of AMR can open the DB, but gets error on submit so the DB is officially hosed)

I thought there might have been something slightly off with my current db because of all the different things that I tried, so I did a complete uninstall, deleted the AMR section of Application Data, and reinstalled from scratch.

I started with a brand new empty database.

I created a brand new user account.

I signed up for one directory.

I added one article

I attempted to create a new Save Category and it still locked up with the "usual" symptoms.

I think I've done all I can to work with this particular version of the beta so I'm calling it quits until the next build. Hopefully I've given you enough so that you can recreate the problem on your side.

Whatever is going on under the covers, 1.0.8 is changing the structure of the db enough to prevent subsequent opens of 1.0.8 and while 1.0.7.6 can open with one of these damaged dbs, it can no longer submit an article. It looks like all the problems start when I attempt to add a new "Save Catagory".

I look forward to the next attempt.

- Leo


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Thu Dec 02, 2010 8:54 am 
Offline
Site Admin

Joined: Thu Apr 08, 2010 3:25 pm
Posts: 3656
Did you by chance do an "update categories" or "Download AMR Cats' ..?


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Thu Dec 02, 2010 10:06 am 
Offline

Joined: Sun Oct 31, 2010 2:42 am
Posts: 25
I'm certain I never tried the download catagories, but I think I did do the update catagories from time to time on different attempts.

Not exactly sure when in the process I did it though, and I definitely did not do either of these on the last time I broke it from the clean install. I did exactly as listed in my other post.

I'm also off to vacation, so I probably won't get a chance to play with things very much for a while but if you have any suggestions, I'll see if I can squeeze things in if the opportunity comes up.

I'm quite eager to get this version ironed out. It's got the last of the features that I really need to go nuts with article marketing!

- Leo


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Fri Dec 03, 2010 7:55 am 
Offline

Joined: Sun Sep 19, 2010 10:37 pm
Posts: 79
I did two full runs on your new version and it worked like a breeze, will keep posting here if i encounter something, nothing till now.


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Sat Dec 04, 2010 9:27 am 
Offline

Joined: Sun Oct 31, 2010 2:42 am
Posts: 25
Rama,

Did you happen to use the new feature that changes the default submission setting so that you only submit to articles that match your catagories?

If so, could you detail the exact steps you used, just to make sure I'm not missing something?

Thanks!


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Tue Dec 07, 2010 9:54 am 
Offline

Joined: Thu Sep 30, 2010 8:48 am
Posts: 12
I am going to try to run this on a separate computer so as not to affect the existing installation.

Is that ok? will it work?


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Fri Dec 10, 2010 10:33 pm 
Offline

Joined: Tue Nov 23, 2010 12:20 am
Posts: 3
I'm in Leo's situation with the exact issues he has reported - and I'm also running XP with SP3 and fully updated.

Everything works great, and I especially love being able to spin the anchor text with a list of links in the resource box. This solves a huge problem of mass article submissions being fingerprinted by Google as all having the same anchor text/link.

The URL'er is awesome, and makes merging the two lists of URLs and keywords as quick as a flash.

The submission seems to be fine and is running sweetly as I type this.

All my problems only relate to the Save Category issue exactly the same as reported by Leo, and the only way to recover from the crash/lock-up of the Beta version is to recopy your back-up database over the damaged one in \Applications Data\Article Marketing Robot folder (which is different to your Program Files\Article Marketing Robot folder).

I also note the Bookmarking tab - which seems to be an excellent development path for AMR when it is realised.


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Thu Dec 16, 2010 2:30 pm 
Offline

Joined: Mon Oct 04, 2010 2:09 pm
Posts: 14
Ok I'm having a small conniption, maybe its something else, but I installed this beta and the program is giving me these multiple licenses error. I can't log into my stuff and have really grown to rely on this program in my arsenal...

EDIT-
Issue was resolved by rebooting.

Seems to be running smooth on Win 7 32bit. I do however notice this eats up alot more memory than 1.0.7.6

I also notice the window doesnt expand out, like the program stays fixed at a certain sized GUI, dont recall previous doing this.

Also the program seems to be a bit different from 1.0.7.6 as in it seems graphics wise a little buggy. As in doing anything in the program seems like a slight hesitation as the previous version did not react this way.


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Mon Dec 20, 2010 2:50 pm 
Offline

Joined: Mon Dec 20, 2010 2:17 pm
Posts: 3
I also had the problem with catagories.

Running Windows 7 64bit with updates.


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Tue Jan 11, 2011 2:52 am 
Offline

Joined: Tue Jan 11, 2011 2:32 am
Posts: 1
Hi,
Did you released a newer version?
If not, do you have an estimation date?
Thanks!


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Tue Jan 11, 2011 1:55 pm 
Offline

Joined: Wed Sep 29, 2010 12:41 pm
Posts: 30
Can we please please please get an eta on this? This week? This month? Still a few months away?

I've been holding up some stuff waiting for the functionality, but if the new release won't be available soon, I'll go ahead and move forward with the existing version.

It would be really, really helpful to have a general eta to know how to proceed.
Thanks


Top
 Profile  
 
 Post subject: Re: Beta Test 1.0.8.*
PostPosted: Thu Jan 13, 2011 8:59 pm 
Offline

Joined: Sat Nov 20, 2010 11:02 am
Posts: 24
Yeah... I've been visiting this page several times hoping to see the new release.
Appreciate all your hardwork and beta tester.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 22 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
[ Time : 0.247s | 16 Queries | GZIP : Off ]